Missing notes in du-musics and other instabilities :-/

Hi everyone! When I record a du-music loop, I find that sometimes notes are missing during playback. At first I thought I am going crazy so today I recorded myself reproducing the issue on video which I have shared at https://www.icloud.com/photos/#0Sg3zI5llJUoTTa6O1wADB6vQ for your reference (sorry minor lag between video and audio).

What to look for in that video:
-- at 0:31 (about 3/4 into the loop) I am playing "F-Eb-D-Eb" while recording a loop
-- at 1:03 (a the same time in the loop of course) you can hear the notes playing back but with the first Eb note entirely missing from the loop. It sound like "F-pause-D-Eb" instead.

This example is very obvious, but it also occurs with chords sometimes where the chord was definitely played correctly while recording a loop, but when playing the loop one of the notes in the chord is missing (for example I only hear two notes instead of three).

In the above video, I'm recording with Tempo 60 and the quantizer is set to 1/8. My du-touch is running firmware v3.3.1. Other issues with instability are:
-- For example I may have two loops already recorded with the metronome and everything is fine. Then I try to record a third loop which is tricky to play, so I may have to try several times (tapping the music button twice to delete and try again). After doing this a few times, the metronome might get completely out of sync with my music which is very irritating and I haven't figured out how to fix it after it gets into this state.
-- Sometimes after turning the du-touch on, I cannot get the metronome sound to work. When I change the metronome type, I can only make the light pulse work, but not the sound, even though I checked that the metronome type is set to "sound" (or "both") and the metronome volume is up. When this happens, the only way to get the metronome sound back is to reset the du-touch with a toothpick. I have to do this about once or twice every day.
-- this happened twice today: When using the quantizer and recording a drum at the same speed as the quantizer, when I'm finished recording the loop the du-touch may simply just freeze with the record symbol still showing on the display. The toothpick reset is needed then.

What I would like to try but am afraid of:
I thought about doing a factory reset, hoping it would help. But I spent a lot of time arranging my sound bank, and I'm worried about losing it. Maybe there's a good way to back up the various instrument and slot assignments, so it can be easily restored after a factory reset? I wouldn’t even mind if it took a few hours to restore as long as i don’t have to do it by hand :-)

Do you have any ideas for troubleshooting? Thanks in advance!

Comments

  • Hello, thanks for this precise feedback

    That behavior is odd and I've never experienced it, but I almost never make loops as long as yours, so maybe it's because of that ?

    I'd say it was because of the quantizer but indeed it seems a bit strange at first sight. Do you have the same kind of issue when not using the quantizer ? I'd say the 1/8 quantizer is "statistically less used" and I don't really see why it wouldn't work correctly, but have you tried to make your song at 1/4 and 120 BPM instead ?

    If you have 7 tracks taken, the metronome won't work (because it actually needs one on its own, and once your piece is already 6 tracks long, you mostly don't need the metronome anymore.
    For the metronome getting out of sync I hear you and I know what you are talking about. I will bring this info to the team. Normally you can stop the du-music and start it again to sync the metronome to the beginning of your du-music

    For the freeze it is kinda unusual, if it happens all the time with the same instrument, the du-sound itself might have a problem I guess.
    I'm not sure the factory reset will help, but if your memory is fragmented I think a cleanup is a good idea anyway. There are (still) no fast and easy way to do it unfortunately...

  • Hi Sergueï, thanks for your quick response!

    re the big issue with the missing notes:
    Your hunch is correct - with the quantizer off, I can't reproduce the missing notes issue.

    So I tried to play around a bit to see if anything else influences the issue, but I wasn't very successful. Nonetheless, for reference, here's what I tried:
    -- I created a new music (empty slot) and changed it to 120 BPM with quantizer at 1/4. This still resulted in the same issue, but as that's a "statistically more used" configuration, I kept this for all subsequent tests, just to rule a 1/8 quantizer out as the cause.
    -- I created a loop that was only half the length of my original recording, but the issue occurred, sometimes even on the first few beats.
    -- The issue occurred even when recording the first track/loop (with metronome on), or when recording the second track/loop (while the first is a "fake metronome" percussion helper track, and actual metronome turned off).
    -- With metronome on, I created the first track/loop in two ways: Once using single notes (polyphonic turned off) using the flute/ocarina instrument, and once using chords with the soft pad/warm pad instrument. single notes ended up missing occasionally in most of my attempts, and some of the triad chords were missing two of their three tones, sometimes for several subsequently-played chords, making it sound like I'm playing single notes.

    I hope this helps shed more light on the missing notes issue. Please let me know if there's anything else I should try or if you want another short video of it.

    re metronome out of sync:
    thanks! I usually do turn the metronome off for musics that have a percussion track after I recorded percussion. But for some of the more ethereal songs may not have percussion at all, in which case I may need the metronome much longer. While I certainly would love to see a fix some day, I also like the idea of using a percussion "helper track", especially for less common rhythms such as 5+3 :-D

    re no metronome sound at all:
    this turned out to be a general sound output problem. when it happened again today, I realized there's no sound output at all in that case. Turning it on and off again sometimes solves this (or using a tooth pick). However, I did notice something I wanted to call out: Normally, when turning the du-touch on (or off) there's a characteristic and unpleasant static click on the sound output. When this unexpectedly doesn't happen at power-on, then there will also not be any other sound output (incl. no metronome of course). Not sure if that's some amp circuit that isn't reliably turning on sometimes, or something like that.

    re freeze:
    I was unable to reproduce this today. if it happens again, I'll take note of the exact instrument and see if it's instrument-specific.

    Thanks again. Overall, I cannot praise the user experience of the du-touch enough. The du-touch has brought me back in touch with making music, helped me understand music theory better, and the UX design is just so well-rounded and well-engineered, it's a true pleasure.

    Cheers,
    -volty

Sign In or Register to comment.