Problems with my Dualo S - in Los Angeles, CA (solved)

Hi Serguei and dualo team,

I purchased my Dualo last year from Sergueï in person, while I was in Paris. I played with it once... and then put it in its bag, and hadn't touched it until today.... Now.. almost a year later, I finally (yes I know...) found the time to play with it. when I did... the instrument didn't make any sounds, and was showing "Err" anytime I pressed any buttons.

I didn't panic.. and decided to connect it to my computer, and tried to update the firmware. I downloaded the Du-Station software on my mac, and sure enough, it immediately told me to update the firmware to 3.3.1. I did, and it was successful. the ERR messages disappeared, but now, all I get is numbers. anytime I press on any button, the screen just shows numbers!

The button on the left (the squiggly line) doesn't respond to any touch. The button on the left (the tuning fork) responds fine, but just seems to be the settings menu. and nothing happens there either!

any idea what's going on? I'm really disappointed that I can't play with it. please help

Fahd

Comments

  • Hello Fahd !

    You seem to be in a particular mode, in the settings menu make sure to set the "MIDI mode" parameter to ctrl/synth/seq and things should work fine.

    If "Err"s are still there after that, reset the Intuitive Instruments du-sounds ("du-touch" tab, takes about 2 hours).

  • Hey Sergueï, your diagnosis was spot on!!!

    after correcting the Midi mode in the settings, and then 2 hours later, updating the du-sounds... it's all working like a charm!

    thank you so much for the quick response and guidance.

    hope you're doing well and staying safe!

Sign In or Register to comment.