No MIDI out on the S?

I have my S, at firmware version 1.1.1.

MIDI out via USB doesn't seem to work: Plugging it in, the computer (a Mac) recognizes the du-touch's MIDI ports - but playing the keyboards, while playing the synth, sends no MIDI out to the computer.

I have the midi mode set to ctrl/seq/synth, though I've tried the others as well. There is also a 4th mode, not listed in the manual: "live" -- wonder what that does! (No, it doesn't send MIDI out.)

Is MIDI out expected to work in this release?

Comments

  • It seems so. I don't have any other USB midi devices so I could verify that another instrument would work, but on my linux I can see the midi device (with aseqdump -l or aconnect -i), but trying to dump the midi messages never shows anything.
  • Hi, indeed it seems that the MIDI is not working as it should.
    The dualo engineers are now aware of that and maybe the next update will correct this issue.

    Thank you for your feedback
  • Any update on when this might be? Did it work in past releases?

    One of the major things I bought the du-touch for was to be a MIDI controller for other things, and both bluetooth and USB MIDI were major features on the Kickstarter stte.
  • edited August 2017
    Hi, for MIDI use, you have to plug your du-touch first, and then turn it on.
    This tricky thing is corrected for the next update, arriving shortly.


  • This doesn't seem to work for me at all:

    * du-touch off, plug in USB, see MIDI over USB show up on computer.
    * press power on on du-touch, see MIDI channel drop, then reappear on computer.
    * now playing keys plays sounds, but no MIDI on computer.

    Makes no difference what MIDI mode is selected on du-touch.

  • On linux plugging in first seems to help. I turned Dualo on after the screen showed the battery status and the right side keys lit up in orange. Then running `aseqdump -p 28` shows incoming events when I press keys (with aftertouch), turn the instrument (accelerometer) or use the sliders.

    Thanks for the workaround! I'm disappointed that the software wasn't done even after the long battery delay, but this way I can at least have corded functionality working. I don't yet have a bluetooth adapter for my desktop, so would be interested about hearing experiences with wireless play. But I assumed the latency might always be a problem, so I was aiming mostly for wired and got a nice long cable.
  • Seems like it was just a fluke. Now that I actually tried to use qsynth, I didn't get any sound and reverifying with aseqdump showed no midi events at all. I tried plugging the cable and turning the dutouch S on at different times, but the only effect was that sometimes the rightside keys lit up in orange and sometimes not, but midi never worked after my lucky try earlier.

    I don't know if you need to have an extremely precise timing when starting it up or what, but I just can't get it working anymore.
  • One month later, no update or workaround. When can we expect to be able to play Dualo with an external synth?

  • The MIDI has been fixed, are you up to date ?
    Else, can you explain exactly what is not working ?

  • I hadn't noticed that there are new firmware versions. I don't run the du-station regularly, as I don't use it for anything. I checked the forums and the support site, but didn't see any news about a new firmware.

    I'll try it later today at home.

Sign In or Register to comment.